Let’s Configure LDP Simpler Way on Cisco!

LDP Topology

Today, we will explain what LDP is and how it is configured in large network in simpliest way. In previous post, we have examined how MPLS topology works. In MPLS network, two LSR devices should agree about labels in order to forward the traffic according to labels. So there are many label distribution protocols that provide this. LDP is one of them and it is Label Distribution Protocol which was introduced first in RFC3036 and later in RFC5036. Then, we will talk about mpls ldp autoconfig.

One of the advantage of LDP is simple configuration method comparison to other label protocols. For example, RSVP is more complex. Below, you will see standard LDP configuration in Cisco devices. But there is more simplier configuration method in MPLS network and it will provide easier way in large topologies.

Above topology shows simple MPLS network. All routers are OSPF adjacent and they advertise their loopback addresses to each other. To enable LDP adjacency, we configured “mpls ip” command each interface that is required labeling. 8 interfaces in this topology have this command to enable LDP. Therefore, that means complexity. You will see P configuration example for this below.

How to MPLS Configuration in Cisco?

nterface Loopback1
ip address 10.5.5.5 255.255.255.255
!
interface FastEthernet0/0
ip address 10.1.1.10 255.255.255.252
duplex auto
speed auto
mpls ip
!
interface FastEthernet0/1
ip address 10.1.1.14 255.255.255.252
duplex auto
speed auto
mpls ip
!
interface FastEthernet1/0
ip address 10.1.1.6 255.255.255.252
duplex auto
speed auto
mpls ip
!
interface FastEthernet2/0
ip address 10.1.1.2 255.255.255.252
duplex auto
speed auto
mpls ip
!
router ospf 1
router-id 10.5.5.5
log-adjacency-changes
network 10.0.0.0 0.255.255.255 area 0

As you see, you configure LDP on each interfaces of devices that need label protocol. After this, LDP neighborship will be seen as above in P router.However, what happens if more devices exist in topology? In such a compexity, to enable LDP in each interface need more time and troubleshooting.You shoud be careful not to miss any interface during configuration. Here, we can use “mpls ldp autoconfig” command under IGP protocols. Currently, only OSPF and IS-IS support this feature. This provides to enable LDP protocol on interfaces which is used for OSPF adjancecy. Instead of configuring each interfaces in MPLS network, you simply add autoconfig command to complete it. In a result, this command will provide simplicity. There is sample config of P router below. Remember, all routers have to be configured mpls ldp autoconfig.

router ospf 1
mpls ldp autoconfig
router-id 10.5.5.5
log-adjacency-changes
network 10.0.0.0 0.255.255.255 area 0

We hope this short article will be useful for you.

Thanks!

Mahmut Aydin
CCIE R&S #63405

Leave a Reply

Top